Back to overview
Resolved

Scheduled maintenance: brief VPS restart today, 4 PM New York time

Jul 18, 2026 at 8:00pm UTC  –  Jul 18, 2026 at 9:00pm UTC
Affected services
TradoxVPS Core Infrastructure (Chicago, US)

Resolved
Jul 18, 2026 at 9:00pm UTC

Maintenance ended

Created
Jul 18, 2026 at 8:00pm UTC

A quick heads up about brief scheduled maintenance on the server your VPS runs on.

When: today, Saturday, 4:00 PM to 5:00 PM New York time (EST)

What's happening: we're applying a routine security update to the host server, which needs a short restart. Your VPS will be offline for a few minutes during that window and will come back automatically once the server restarts. We chose this time because the futures markets are closed over the weekend, so it shouldn't affect any active trading.